CVE-2026-92162: flatpak · Path Traversal
Affects flatpakSource CVE Database V5
Not known to be exploited · CVSS 7.2 High : upgrade to 1.18.1 soon.
Data as of 26 Oct 2026, 17:30 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2026-10-20.
- Patch
- Available – fixed in 1.18.1
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade flatpak to 1.18.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| flatpakflatpak | Affected
| Fixed in
|
Description
Flatpak is a system for building, distributing, and running sandboxed desktop applications on Linux. Prior to version 1.18.1, on systems where at least one OCI remote is configured (most common on Fedora systems), a malicious local user in an active local session could use a crafted architecture name to trick the `flatpak-system-helper` process into creating a root-owned directory tree with contents determined by the OCI remote, plus a root-owned `lock` file and `icons` directory, outside the intended root directory. If this vulnerability is combined with other vulnerabilities also fixed in 1.18.1, the combination can lead to local root privilege escalation. This particular vulnerability is not believed to be exploitable if there are no OCI remotes configured (common on non-Fedora systems). Version 1.18.1 patches the issue.
References
- github.com/flatpak/flatpak/security/advisories/GHSA-v2gw-v9h5-9q4x (opens in a new tab)
- github.com/flatpak/flatpak/pull/6768 (opens in a new tab)
- github.com/flatpak/flatpak/commit/01773f84021dd090b2426f79675f94f2564f9279 (opens in a new tab)
- github.com/flatpak/flatpak/commit/19456b916842b079af833a86b9ab89c5db154b92 (opens in a new tab)
- github.com/flatpak/flatpak/commit/aeb369a2723506fabc1f701ef7a0dc6c97c4b983 (opens in a new tab)