CVE-2026-92474: GPAC · Use After Free
Affects GPACSource CVE Database V5
Public exploit available · CVSS 4.8 Medium.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GPAC | Affected
| Fixed in– |
GitHubgpac/gpacpkg:github/gpac/gpacOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:gpac:gpac:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade GPAC to version abi-16.24 or later, which contains the official fix for this vulnerability. Applying this update mitigates the use-after-free flaw. No additional mitigation actions are specified or required beyond upgrading.
Description
A security flaw has been discovered in GPAC 26.08-DEV. This affects the function gf_inline_get_proto_lib of the file src/compositor/mpeg4_inline.c of the component Proto Link Handler. The manipulation results in use after free. The attack requires a local approach. The exploit has been released to the public and may be used for attacks. Upgrading to version abi-16.24 mitigates this issue. The patch is identified as e34f4ba349d55cd1849f0bcf4cf46552732e2db7. Upgrading the affected component is recommended.
References
- vuldb.com/vuln/405733 (opens in a new tab)
- vuldb.com/vuln/405733/cti (opens in a new tab)
- vuldb.com/cve/CVE-2026-92474 (opens in a new tab)
- vuldb.com/submit/941005 (opens in a new tab)
- github.com/gpac/gpac/issues/3829 (opens in a new tab)
- github.com/user-attachments/files/30635900/poc_01.zip (opens in a new tab)
- github.com/gpac/gpac/commit/e34f4ba349d55cd1849f0bcf4cf46552732e2db7 (opens in a new tab)
- github.com/gpac/gpac/releases/tag/abi-16.24 (opens in a new tab)
- github.com/gpac/gpac/ (opens in a new tab)