Skip to main content
VulnerabilityPublished Updated

CVE-2026-92518: Linux kernel · riscv, bpf: Fix kernel stack corruption in tailcall with CFI

Affects Linux kernelSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High · fixed in a6e11a81da3420fd37f1518d4f238c4d5784086e : patch Linux kernel soon.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in a6e11a81da3420fd37f1518d4f238c4d5784086e, 52fb1756ea1d2759dfef2d86245be00b05dac3a2, 34b1bb33a025787e05f966e74de18cd36276f801 +1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Linux kernel to a6e11a81da3420fd37f1518d4f238c4d5784086e, 52fb1756ea1d2759dfef2d86245be00b05dac3a2, 34b1bb33a025787e05f966e74de18cd36276f801 or 6.12.

Affected software

ProductAffectedFixed in
LinuxLinuxAffected
  • >=6.11.6 <6.12
Fixed in
  • a6e11a81da3420fd37f1518d4f238c4d5784086e
  • 52fb1756ea1d2759dfef2d86245be00b05dac3a2
  • 34b1bb33a025787e05f966e74de18cd36276f801
  • 6.12
LinuxLinuxAffected
  • =6.12
Fixed in–

AI-suggested

A fix for this vulnerability is available in Linux kernel version 6.12 and specific commits. Users and administrators should upgrade to version 6.12 or later to remediate this issue. No additional mitigation steps are indicated beyond applying the official patch.

Description

CVE-2026-92518 is a high-severity vulnerability in the Linux kernel affecting versions 6.11.6 through 6.12. It involves kernel stack corruption caused by an incorrect tailcall jump offset when CONFIG_CFI_CLANG is enabled. This flaw leads to skipping the stack pointer adjustment, resulting in kernel stack corruption.

References

Community reviews

Loading reviews…