Skip to main content
VulnerabilityPublished Updated

CVE-2026-9256: F5 NGINX Plus · Heap-based Buffer Overflow

Affects F5 NGINX PlusSource CVE Database V5

0
Compare

Not known to be exploited · 10% EPSS · CVSS 8.1 High : upgrade to 37.0.1.1 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
10.8% chance of exploitation in 30 days – higher than 95% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 37.0.1.1, 1.31.1, 1.30.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade NGINX to 37.0.1.1 (Plus); 1.31.1 or 1.30.2 (Open Source).

Affected software

ProductAffectedFixed in
F5NGINX PlusAffected
  • >=37.0 <37.0.1.1
  • =R36
  • =R32
Fixed in
  • 37.0.1.1
F5NGINX Open SourceAffected
  • >=1.31.0 <1.31.1
  • >=1.30.0 <1.30.2
  • >=0.1.17 <=0.9.7
Fixed in
  • 1.31.1
  • 1.30.2

AI-suggested

Red Hat has issued security updates that fix this vulnerability. Users should apply the provided patches from Red Hat Enterprise Linux 10 and related distributions as detailed in the Red Hat advisories (e.g., RHSA-2026:29874). Since this is not a cloud service, remediation requires updating affected software versions. Patch status is confirmed by Red Hat advisories. No alternative mitigations are specified.

Description

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_rewrite_module module. This vulnerability exists when a rewrite directive uses a regex pattern with distinct, overlapping Perl-Compatible Regular Expression (PCRE) captures (for example, ^/((.*))$) and a replacement string that references multiple such captures (for example, $1$2) in a redirect or arguments context. An unauthenticated attacker along with conditions beyond their control can exploit this vulnerability by sending crafted HTTP requests. This may cause a heap buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

References

Community reviews

Loading reviews…