CVE-2026-92592: craftcms cms · Template Injection
Affects craftcms cmsSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 4.18.6 soon.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.18.6, 5.10.13
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade cms to 4.18.6; cms to 5.10.13; craftcms/cms to 5.10.13 or 4.18.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| craftcmscms | Affected
| Fixed in
|
| craftcmscms | Affected
| Fixed in
|
GitHubcraftcms/cmspkg:github/craftcms/cmsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Craft CMS to version 4.18.6 or later, or 5.10.13 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory. Ensure two-factor authentication is enabled to reduce risk, as exploitation requires password authentication without 2FA.
Description
Craft CMS versions 4.8.0 through 4.18.5 and 5.0.0 through 5.10.12 contain a vulnerability where an authenticated non-administrator user can execute arbitrary operating system commands. This occurs due to improper binding of HMAC signatures to their purpose, allowing an attacker to reuse a signed cookie in a redirect parameter that is rendered as an unsandboxed Twig template. The issue requires password authentication without 2FA and availability of PHP system(). The vulnerability is fixed in versions 4.18.6 and 5.10.13.