Skip to main content
VulnerabilityPublished Updated

CVE-2026-92812: decaporg decap-cms · Path Traversal

Affects decaporg decap-cmsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 3.11.0 as a priority.

Data as of 1 Nov 2026, 08:20 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.09.3
CNA (VulnCheck)CVSS 3.19.8
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.11.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade decaporg decap-cms to 3.11.0.

Affected software

ProductAffectedFixed in
decaporgdecap-cmsAffected
  • <3.11.0
Fixed in
  • 3.11.0
GitHubdecap-cmspkg:github/decap-cmsOther threatsAffected
  • <3.11.0
Fixed in
  • 3.11.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade decap-cms to version 3.11.0 or later, where this path traversal vulnerability is fixed. No other mitigation is indicated by the vendor advisory.

Description

Decap CMS versions prior to 3.11.0 have a critical path traversal vulnerability in the local proxy containment guard. The vulnerability arises from improper pathname limitation using plain string prefix comparison without validating path separators. This flaw allows attackers to access sibling directories with names starting like the repository directory, enabling unauthorized reading, writing, or deletion of files outside the intended repository root. The issue is fixed in version 3.11.0.

References

Community reviews

Loading reviews…