Skip to main content
VulnerabilityPublished

CVE-2026-92903: Snowflake CLI · SQL Injection

Affects Snowflake CLISource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.2 High : upgrade to 3.27.0 soon.

Data as of 1 Nov 2026, 11:03 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.27.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade Snowflake CLI and snowflake-cli and snowflake-cli-labs to 3.27.0.

Affected software

ProductAffectedFixed in
SnowflakeSnowflake CLIAffected
  • <3.27.0
Fixed in
  • 3.27.0
PyPIsnowflake-clipkg:pypi/snowflake-cliOther threatsAffected
  • <3.27.0
Fixed in
  • 3.27.0
PyPIsnowflake-cli-labspkg:pypi/snowflake-cli-labsOther threatsAffected
  • <3.27.0
Fixed in
  • 3.27.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Snowflake CLI version 3.27.0. Users must manually upgrade to this version or later to remediate the vulnerability. No other mitigations are indicated by the vendor advisory.

Description

Improper input validation in Snowflake CLI versions prior to 3.27.0 allowed unsanitized user-controlled values to be interpolated into SQL strings that are executed as multi-statement queries. An attacker who is able to supply a malicious project configuration file or craft command-line input can cause Snowflake CLI to execute attacker-controlled SQL statements in the context of the victim's Snowflake session and active role. Successful exploitation requires either write or pull-request access to a project repository whose CI/CD pipeline runs Snowflake CLI under an elevated service account role, or the ability to supply untrusted input to CLI-wrapping automation. Impact is limited by the privileges held by the configured Snowflake role at execution time. The fix is available in Snowflake CLI version 3.27.0, which also addresses several additional security findings. Users must manually upgrade.

References

Community reviews

Loading reviews…