CVE-2026-92953: patriksimek vm2 · Improper Control of Dynamically-Managed Code Resources
Affects patriksimek vm2Source CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 3.11.8 as a priority.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.11.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade patriksimek vm2 to 3.11.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| patriksimekvm2 | Affected
| Fixed in
|
npmvm2pkg:npm/vm2Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade vm2 to version 3.11.8 or later where this vulnerability is fixed. No other mitigation or temporary workaround is indicated. Patch status is confirmed by the affected version range and the fixed version 3.11.8.
Description
CVE-2026-92953 is a critical vulnerability in patriksimek vm2 affecting versions 3.11.0 up to but not including 3.11.8. The flaw allows attackers to mutate host TypedArray and ArrayBuffer prototypes from within the sandbox environment, leading to host-created typed arrays inheriting attacker-controlled properties after VM.run() execution.