CVE-2026-92954: patriksimek vm2 · Uncaught Exception
Affects patriksimek vm2Source CVE Database V5
Not known to be exploited · CVSS 9.2 Critical : upgrade to 3.11.8 as a priority.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.11.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade patriksimek vm2 to 3.11.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| patriksimekvm2 | Affected
| Fixed in
|
npmvm2pkg:npm/vm2Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade vm2 to version 3.11.8 or later, where this issue is fixed. No other mitigations are indicated by the vendor advisory.
Description
CVE-2026-92954 is a critical vulnerability in the vm2 sandbox library for Node.js versions 3.10.0 through 3.11.7. It involves improper handling of Promises returned from the host environment into the sandbox, which can cause unhandled Promise rejections in the host process. This may lead to the termination of the host Node.js process. The issue is fixed in version 3.11.8.