CVE-2026-92958: patriksimek vm2 · Improper Privilege Management
Affects patriksimek vm2Source CVE Database V5
Not known to be exploited · CVSS 8.4 High : upgrade to 3.11.7 soon.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.11.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:H/SA:LExploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade patriksimek vm2 to 3.11.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| patriksimekvm2 | Affected
| Fixed in
|
npmvm2pkg:npm/vm2Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to vm2 version 3.11.7 or later, where this builtin-module denylist bypass is fixed. No other mitigation is required as the fix addresses the root cause of the privilege bypass.
Description
CVE-2026-92958 is a high-severity vulnerability in the patriksimek vm2 library up to version 3.11.6. It involves an improper privilege management issue where the builtin-module denylist in NodeVM can be bypassed. Specifically, when using a builtin wildcard with negative entries to restrict modules, subpaths of denied modules such as fs/promises remain accessible. This allows sandboxed code to require and use promise-based filesystem APIs despite restrictions. The vulnerability enables unauthorized file creation and modification operations. The issue is fixed in vm2 version 3.11.7.