Skip to main content
VulnerabilityPublished Updated

CVE-2026-93224: Linux kernel · svcrdma: Fix unmatched rn_unregister on failed accept

Affects Linux kernelSource CVE Database V5

0

Not known to be exploited · CVSS 8.1 High · fixed in 0335800071a6dfdf7d21d729b5e7d8fa98936211 : patch Linux kernel soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0335800071a6dfdf7d21d729b5e7d8fa98936211, 26190394c64c9429481fc88a4738f70bb92fb352, 45a444a17240f4fa2235f0dfd4a96fc80f1eb2c2 +3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
LinuxLinuxAffected
  • >=6.12.35 <6.12.109
  • >=6.15.4 <6.16
Fixed in
  • 0335800071a6dfdf7d21d729b5e7d8fa98936211
  • 26190394c64c9429481fc88a4738f70bb92fb352
  • 45a444a17240f4fa2235f0dfd4a96fc80f1eb2c2
  • 6.16
  • 6.12.109
  • 5aabe070c00e5bdf4ab150fb5f72ad5f266d6241
LinuxLinuxAffected
  • =6.16
Fixed in–

AI-suggested

A fix is available and included in Linux kernel versions 6.12.109 and 6.16. Users and administrators should upgrade to these or later versions to remediate the vulnerability. No additional mitigation steps are indicated beyond applying the official patch.

Description

CVE-2026-93224 is a high-severity vulnerability in the Linux kernel's svcrdma component affecting versions >=6.12.35 <6.12.109, >=6.15.4 <6.16, and =6.16. It involves improper cleanup during failed RDMA accept operations, leading to resource leaks and potential memory corruption. The issue is fixed in Linux kernel versions 6.12.109 and 6.16.

References

Community reviews

Loading reviews…