Skip to main content
VulnerabilityPublished Updated

CVE-2026-93272: Linux kernel · remoteproc: qcom_wcnss: Fix handling the lack of PD regulators in v3

Affects Linux kernelSource CVE Database V5

0

Not known to be exploited · fixed in e572cbb513cde53d90fb4729cad75056cd647ce3 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 20:11 UTC

Severity
Low

Rated Low by Threat Radar's AI analysis · CVSS not yet scored by NVD

EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in e572cbb513cde53d90fb4729cad75056cd647ce3, bce6b48af3abf7468d12ef4933f21bd8c1d822e9, 7abab59d6c99ba2b8101d6f44ad25159b1510724 +7

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
LinuxLinuxAffected
  • >=6.6.93 <6.6.160
  • >=6.12.31 <6.12.114
  • >=5.15.185 <5.16
  • >=6.1.141 <6.2
  • >=6.14.9 <6.15
Fixed in
  • e572cbb513cde53d90fb4729cad75056cd647ce3
  • bce6b48af3abf7468d12ef4933f21bd8c1d822e9
  • 7abab59d6c99ba2b8101d6f44ad25159b1510724
  • 6.15
  • 6.12.114
  • 6.6.160
  • 6.2
  • 5.16
  • 3dbc90b9c22ea96e37bf55f6011e63b5123ec668
  • 2e7e39bb81913feaac463b7add46bafdca06fbde
LinuxLinuxAffected
  • =6.15
Fixed in–

AI-suggested

The issue has been fixed in Linux kernel versions 5.16, 6.2, 6.6.160, 6.12.114, 6.15, and later commits identified by specific hashes. Users and administrators should update to these fixed versions to resolve the vulnerability. No additional mitigation steps are required beyond applying the official patches.

Description

A vulnerability in the Linux kernel's remoteproc subsystem for Qualcomm WCNSS devices was fixed. The issue involved incorrect handling of power domain (PD) regulators in version 3, causing an out-of-bounds pointer increment that led to errors on certain devices, notably SDM632 when compiled with LLVM. This was addressed by adjusting the pointer increment logic to correctly handle cases where there are more power domains than regulators.

References

Community reviews

Loading reviews…