Skip to main content
VulnerabilityPublished

CVE-2026-93328: Google Cloud MCP Toolbox for Databases (googleapis/mcp-toolbox) · Missing Authorization

Affects Google Cloud MCP Toolbox for Databases (googleapis/mcp-toolbox)Source CVE Database V5

0

Not known to be exploited · CVSS 9.3 Critical : upgrade to 1.5.0 as a priority.

Data as of 26 Oct 2026, 17:30 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.5.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Google Cloud MCP Toolbox for Databases (googleapis/mcp-toolbox) to 1.5.0.

Affected software

ProductAffectedFixed in
Google CloudMCP Toolbox for Databases (googleapis/mcp-toolbox)Affected
  • >=1.2.0 <1.5.0
Fixed in
  • 1.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in Google Cloud MCP Toolbox for Databases version 1.5.0. Users should upgrade to version 1.5.0 or later to remediate this vulnerability. As this is a cloud-hosted service, Google manages remediation on their side; users should verify with Google Cloud advisories that their environment has been updated accordingly.

Description

Path Traversal and Missing Authorization in cloud-storage source in Google Cloud MCP Toolbox for Databases (googleapis/mcp-toolbox) versions 1.2.0 through 1.4.0 allows an unauthenticated remote attacker to exfiltrate host files to external Google Cloud Storage buckets and overwrite arbitrary local files via crafted tool invocation parameters.

References

Community reviews

Loading reviews…