Skip to main content
VulnerabilityPublished Updated

CVE-2026-93337: nm-l2tp NetworkManager-l2tp · Argument Injection

Affects nm-l2tp NetworkManager-l2tpSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.5 High · fixed in 1.52.6 : patch nm-l2tp NetworkManager-l2tp soon.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.52.6
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
nm-l2tpNetworkManager-l2tpAffected
  • <=1.52.4
Fixed in–
GitHubNetworkManager-l2tppkg:github/NetworkManager-l2tpOther threatsAffected
  • <=1.52.4
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade NetworkManager-l2tp to version 1.52.6 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory.

Description

NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains an improper input validation vulnerability that allows local users with VPN connection creation permissions to inject arbitrary pppd directives by supplying mru or mtu property values containing trailing non-numeric content after a valid integer. Attackers can exploit the verbatim write of unvalidated strings into the pppd options file via write_config_option() to inject the plugin directive, causing the privileged pppd process to load an attacker-controlled shared object and achieve arbitrary code execution as root.

References

Community reviews

Loading reviews…