Skip to main content
VulnerabilityPublished Updated

CVE-2026-93349: frictionlessdata frictionless-py · OS Command Injection

Affects frictionlessdata frictionless-pySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 5.20.0rc2 or 5.19.1 soon.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.1% chance of exploitation in 30 days – higher than 81% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.20.0rc2, 5.19.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade frictionlessdata frictionless-py to 5.20.0rc2 or 5.19.1.

Affected software

ProductAffectedFixed in
frictionlessdatafrictionless-pyAffected
  • >=5.20.0rc1 <5.20.0rc2
Fixed in
  • 5.20.0rc2
frictionlessdatafrictionless-pyAffected
  • <5.19.1
Fixed in
  • 5.19.1
GitHubfrictionless-pypkg:github/frictionless-pyOther threatsAffected
  • <5.19.1
  • >=5.20.0rc1 <5.20.0rc2
Fixed in
  • 5.19.1
  • 5.20.0rc2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade frictionless-py to version 5.19.1 or later. The vulnerability is fixed in 5.19.1 and also addressed in 5.20.0rc2. Avoid running the explore command on untrusted Data Package descriptors until patched.

Description

Frictionless before 5.19.1 contains an OS command injection vulnerability in the explore console command that allows an attacker who supplies a crafted Data Package descriptor to execute arbitrary operating system commands as the user who explores it. Attackers can place shell metacharacters in resource path values within a datapackage.json descriptor, which are passed unsanitized to os.system through a shell, causing arbitrary command execution in the victim's security context when they run the explore command against the untrusted package. This vulnerability was also addressed in version 5.20.0rc2 of the pre-release branch.

References

Community reviews

Loading reviews…