Skip to main content
VulnerabilityPublished

CVE-2026-93395: MongoDB C Driver · Integer Underflow

Affects MongoDB C DriverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 2.3.1 when convenient.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.3.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade MongoDB C Driver to 2.3.1.

Affected software

ProductAffectedFixed in
MongoDB Inc.C DriverAffected
  • >=2.0.0 <2.3.1
Fixed in
  • 2.3.1

AI-suggested

No explicit patch or remediation is stated in the provided data. If you cannot patch yet, applications should avoid processing untrusted BSON input or implement input validation to ensure BSON document lengths meet minimum size requirements.

Description

CVE-2026-93395 is an integer underflow vulnerability in the bson_new_from_buffer() function of the MongoDB C Driver. The function fails to validate that the BSON document length is at least 5 bytes, allowing a zero-length prefix to cause an integer wraparound. This leads to a heap out-of-bounds read and a process crash, resulting in a denial of service. The vulnerability affects versions from 2.0.0 up to but not including 2.3.1. No known exploits are reported in the wild. The CVSS 4.0 score is 6.9, indicating a medium severity.

References

Community reviews

Loading reviews…