CVE-2026-93524: x.org xwayland · Buffer Over-read
Affects x.org xwaylandSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 24.1.14 when convenient.
Data as of 28 Oct 2026, 17:22 UTC
- Patch
- Available – fixed in 21.1.25, 24.1.14
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade xwayland to 24.1.14; xorg-x11-server and freedesktop/xorg/xserver to 21.1.25.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| x.orgxorg-x11-server | Affected
| Fixed in
|
| x.orgxwayland | Affected
| Fixed in
|
GitHubfreedesktop/xorg/xserverpkg:github/freedesktop/xorg/xserverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to X.Org X Server version 21.1.25 or later and XWayland version 24.1.14 or later, where this buffer over-read vulnerability is fixed. No other mitigations are indicated or required according to the available data.
Description
CVE-2026-93524 is a buffer over-read vulnerability in the CheckKeySyms() function of X.Org X Server and XWayland. It affects versions before 21.1.25 of X.Org X Server and before 24.1.14 of XWayland. Authenticated X clients could exploit this flaw to leak small amounts of memory information or potentially cause a server crash.