Skip to main content
VulnerabilityPublished Updated

CVE-2026-9358: postcss-selector-parser · Uncontrolled Recursion

Affects postcss-selector-parserSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.3 Medium : upgrade to 7.1.3 or 6.1.3 as a priority.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.1.3, 6.1.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade postcss-selector-parser to 7.1.3 or 6.1.3.

Affected software

ProductAffectedFixed in
postcss-selector-parserAffected
  • 6.1.0 – 7.1.2
6 affected builds
Fixed in–
npmpostcss-selector-parserpkg:npm/postcss-selector-parserOther threatsAffected
  • <6.1.3
  • <7.1.3
Fixed in
  • 6.1.3
  • 7.1.3

CPE configurations (1)

  • cpe:2.3:a:postcss-selector-parser:postcss-selector-parser:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available by upgrading postcss-selector-parser to versions 6.1.3 or 7.1.3. Users should apply these updates to remediate the vulnerability. The vendor considers the risk low and notes that most users compile their own CSS, which may reduce exposure. No additional mitigations are specified.

Description

A vulnerability was determined in postcss-selector-parser up to 6.1.2/7.1.2. Affected is the function toString of the file src/selectors/container.js of the component AST Serialization. Executing a manipulation can lead to uncontrolled recursion. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 6.1.3 and 7.1.3 is able to address this issue. This patch is called 5bc698cef66f8abd12610dc623e5d67cbc0f869d. It is suggested to upgrade the affected component. The vendor explains, that according to his definition "DoS on server-side on user-generated CSS is low risk for us (since most users compile own CSS with PostCSS)." The commits were backported to 6.x branch, which was the most downloaded version.

References

Community reviews

Loading reviews…