Skip to main content
VulnerabilityPublished

CVE-2026-93602: rustls webpki · Improper Check for Certificate Revocation

Affects rustls webpkiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 0.104.0-alpha.5 or 0.103.10 when convenient.

Data as of 2 Nov 2026, 10:58 UTC

CVSS 4.0 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.104.0-alpha.5, 0.103.10
CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade webpki and rustls/webpki to 0.104.0-alpha.5 or 0.103.10.

Affected software

ProductAffectedFixed in
rustlswebpkiAffected
  • >=0.104.0-alpha.1 <0.104.0-alpha.5
Fixed in
  • 0.104.0-alpha.5
rustlswebpkiAffected
  • >=0.102.0-alpha.0 <0.103.10
Fixed in
  • 0.103.10
crates.iorustls/webpkipkg:cargo/rustls/webpkiOther threatsAffected
  • >=0.102.0-alpha.0 <0.103.10
  • >=0.104.0-alpha.1 <0.104.0-alpha.5
Fixed in
  • 0.103.10
  • 0.104.0-alpha.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, consider carefully the revocation policy settings and the trustworthiness of issuing authorities.

Description

rustls-webpki versions before 0.103.10 and 0.104.0-alpha.5 contain faulty CRL authority-matching logic that compares only the first distributionPoint against each CRL's IssuingDistributionPoint, ignoring additional distributionPoints. Attackers with a compromised trusted issuing authority can present revoked certificates that pass revocation checks under UnknownStatusPolicy::Allow, or cause incorrect errors under the default deny policy.

References

Community reviews

Loading reviews…