CVE-2026-9365: Ettercap · Heap-based Buffer Overflow
Affects EttercapSource CVE Database V5
Public exploit available · CVSS 6.3 Medium.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 24 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Ettercap | Affected
| Fixed in– |
GitHubettercap/ettercappkg:github/ettercap/ettercapOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:ettercap:ettercap:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Ettercap to version 0.8.4 or later, which includes the official fix for this vulnerability (patch feeae6fa366e01a3dd9f1857ec6aae847b2ae00c). No other mitigation or temporary workaround is indicated. Patch status is confirmed by the vendor's release notes.
Description
A vulnerability has been found in Ettercap up to 0.8.3. The affected element is the function FUNC_DECODER of the file src/dissectors/ec_gg.c of the component GG Dissector. The manipulation of the argument gg leads to heap-based buffer overflow. The attack is possible to be carried out remotely. The complexity of an attack is rather high. The exploitability is described as difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 0.8.4 is sufficient to fix this issue. The identifier of the patch is feeae6fa366e01a3dd9f1857ec6aae847b2ae00c. It is suggested to upgrade the affected component.
References
- vuldb.com/vuln/365328 (opens in a new tab)
- vuldb.com/vuln/365328/cti (opens in a new tab)
- vuldb.com/submit/813142 (opens in a new tab)
- github.com/Ettercap/ettercap/issues/1306 (opens in a new tab)
- github.com/Ettercap/ettercap/pull/1307 (opens in a new tab)
- github.com/Ettercap/ettercap/commit/feeae6fa366e01a3dd9f1857ec6aae847b2ae00c (opens in a new tab)
- github.com/Ettercap/ettercap/ (opens in a new tab)