CVE-2026-93658: uutils coreutils · Improper Preservation of Permissions
Affects uutils coreutilsSource CVE Database V5
Not known to be exploited · CVSS 7.3 High : upgrade to 0.10.0 soon.
Data as of 2 Nov 2026, 10:58 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.10.0
CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 18 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade uutils coreutils to 0.10.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| uutilscoreutils | Affected
| Fixed in
|
crates.iocoreutilspkg:cargo/coreutilsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, avoid running installation processes on capability-restricted systems where ownership changes might fail, or verify ownership and permissions of installed files manually to ensure no setuid executables remain improperly owned.
Description
uutils coreutils versions before 0.10.0 apply setuid or setgid mode to install destinations before finalizing ownership changes, allowing privileged users to leave setuid executables owned by the privileged invoker when ownership changes fail. Attackers can execute leftover setuid files with elevated privileges when ownership change operations fail on capability-restricted systems.
References
- github.com/uutils/coreutils/security/advisories/GHSA-cgg3-923w-v53m (opens in a new tab)
- github.com/uutils/coreutils/pull/13629 (opens in a new tab)
- github.com/uutils/coreutils/commit/7c87ab04fee8e52d989fb2625568a3eeda1b1f55 (opens in a new tab)
- github.com/uutils/coreutils/blob/0.9.0/src/uu/install/src/install.rs (opens in a new tab)
- github.com/uutils/coreutils (opens in a new tab)
- vulncheck.com/advisories/uutils-coreutils-0.0.18-before-0.10.0-privilege-escalation-via-setuid (opens in a new tab)