Skip to main content
VulnerabilityPublished Updated

CVE-2026-93709: Dancer2 (Perl module) · Improper Resolution of Path Equivalence

Affects Dancer2 (Perl module)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 2.2.0 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Dancer2 (Perl module) to 2.2.0.

Affected software

ProductAffectedFixed in
CPANDancer2pkg:cpan/Dancer2Other threatsAffected
  • <2.2.0
Fixed in
  • 2.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The vulnerability affects Dancer2 versions before 2.2.0. Users should upgrade to version 2.2.0 or later where this issue is fixed. If upgrading is not immediately possible, disabling the auto_page feature will prevent the vulnerability from being exploitable. Patch status is not explicitly stated in the input data, so check the vendor advisory for current remediation guidance.

Description

CVE-2026-93709 is a vulnerability in Dancer2 for Perl versions before 2.2.0 where the AutoPage handler improperly resolves path equivalence. This allows certain path variants (such as doubled slashes, dot segments, percent-encoded slashes, or case differences on case-insensitive filesystems) to bypass a guard check and serve a layout as a page. The vulnerability is off by default and only present when auto_page is enabled. The disclosed layout is already public, so the impact is limited to revealing one of the application's other layouts.

References

Community reviews

Loading reviews…