Skip to main content
VulnerabilityPublished

CVE-2026-93894: Vinyl Cache · Out-of-bounds Write

Affects Vinyl CacheSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.3 Low : upgrade to 90f5bacc14b2404e6cc349ba015f0f73b8515136 or 9.0.2 when convenient.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 90f5bacc14b2404e6cc349ba015f0f73b8515136, 9.0.2, c5078ae575201b05ae8674a90ddb19ffe7f4b439 +1
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/AU:N/R:A/V:D/RE:L/U:Clear

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Vinyl Cache to 90f5bacc14b2404e6cc349ba015f0f73b8515136 or 9.0.2; Varnish Cache to c5078ae575201b05ae8674a90ddb19ffe7f4b439 or 9.0.4.

Affected software

ProductAffectedFixed in
Vinyl-CacheVinyl CacheAffected
  • <9.0.2
Fixed in
  • 90f5bacc14b2404e6cc349ba015f0f73b8515136
  • 9.0.2
Varnish-SoftwareVarnish CacheAffected
  • >=9.0.0 <9.0.4
  • >=6.3.0 <=8.0.2
  • =0
Fixed in
  • c5078ae575201b05ae8674a90ddb19ffe7f4b439
  • 9.0.4

AI-suggested

A fix is available in Vinyl Cache version 9.0.2 and later. Users should upgrade to version 9.0.2 or above to remediate this vulnerability. No vendor advisory content was provided to indicate alternative mitigations or temporary workarounds.

Description

CVE-2026-93894 is a workspace buffer overflow vulnerability in Vinyl Cache versions before 9.0.2, specifically in the .upper() and .lower() string methods of VCL. This flaw can be exploited remotely to cause a denial of service by crashing the child process, which then restarts. Exploitation requires detailed knowledge of the VCL in use and crafting a request with a string long enough to overflow the workspace while respecting request size limits.

References

Community reviews

Loading reviews…