Skip to main content
VulnerabilityPublished Updated

CVE-2026-93960: Pixelfed · Missing Authentication

Affects PixelfedSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.3 Medium.

Data as of 3 Nov 2026, 10:58 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
PixelfedAffected
  • 0.12.0 – 0.12.11
12 affected builds
Fixed in–
GitHubpixelfed/pixelfedpkg:github/pixelfed/pixelfedOther threatsAffected
  • 0.12.0 – 0.12.11
12 affected builds
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:pixelfed:pixelfed:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should upgrade Pixelfed to version 0.12.10 or later to remediate this vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

A vulnerability was identified in Pixelfed up to 0.12.11. Impacted is the function instancePeers of the file app/Http/Controllers/Api/ApiV1Controller.php of the component OAuth Scope Handler. Such manipulation of the argument ID leads to missing authentication. The attack may be performed from remote. The exploit is publicly available and might be used. Upgrading to version 0.12.10 is recommended to address this issue. The name of the patch is 68dca5097305fa0065d029587b2233524636025a. Upgrading the affected component is advised.

References

Community reviews

Loading reviews…