Skip to main content
VulnerabilityPublished Updated

CVE-2026-94050: D-Link DIR-X1860Z · Information Disclosure

Affects D-Link DIR-X1860ZSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium · end of life, no fix coming : replace or isolate D-Link DIR-X1860Z; no fix will be released.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
None coming – the product is end of life
CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

No fix will be released: D-Link DIR-X1860Z is end of life. Replace it, or isolate it from untrusted networks until you can.

Affected software

ProductAffectedFixed in
D-LinkDIR-X1860ZAffected
  • =1.0.2.220120.165402
Fixed in–

CPE configurations (1)

  • cpe:2.3:h:d-link:dir-x1860z:*:*:*:*:*:*:*:*

AI-suggested

Upgrade the affected device firmware to version 1.0.7.260821.161908 or later to remediate this vulnerability. Since the affected products are no longer supported, users should consider device replacement if upgrading is not possible.

Description

A vulnerability has been found in D-Link DIR-X1860Z up to 1.0.2.220120.165402. Affected is the function routerd.wificfg_get/routerd.get_rand_key of the component ubus JSON-RPC interface. Such manipulation leads to information disclosure. The attack must be carried out from within the local network. Upgrading to version 1.0.7.260821.161908 is able to address this issue. It is suggested to upgrade the affected component. This vulnerability only affects products that are no longer supported by the maintainer.

References

Community reviews

Loading reviews…