CVE-2026-94301: Apache MINA · Deserialization of Untrusted Data
Affects Apache MINASource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 9.8 Critical : upgrade to 2.1.15 or 2.0.31 as a priority.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.1.15, 2.0.31
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade Apache MINA and org.apache.mina/mina-core to 2.1.15 or 2.0.31.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache MINA | Affected
| Fixed in
|
| Apache Software FoundationApache MINA | Affected
| Fixed in
|
Mavenorg.apache.mina/mina-corepkg:maven/org.apache.mina/mina-coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, consider avoiding use of affected versions or applying any recommended temporary mitigations from the vendor.
Description
CVE-2026-94301 is a critical deserialization vulnerability in Apache MINA that affects versions 2.0.0 up to but not including 2.0.31 and 2.1.0 up to but not including 2.1.15. The flaw results from a missing override of the resolveProxyClass() method in these branches, which allows an allow-list bypass. This vulnerability has a CVSS score of 9.8, indicating a severe impact on confidentiality, integrity, and availability. No known exploits have been reported in the wild. The vulnerability is distinct from the 2.2.x branch, where the related issue was fixed. No official patches or vendor advisories are provided in the input data.