CVE-2026-94450: s2n-quic · Potential denial of service when configured to send Retry packets
Affects s2n-quicSource AWS Security Bulletins
Not known to be exploited · CVSS 7.5 High · fixed in 1.89.0 : patch s2n-quic soon.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 1.9% chance of exploitation in 30 days – higher than 80% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.89.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 22 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
crates.ioaws/s2n-quicpkg:cargo/aws/s2n-quicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade s2n-quic to version 1.89.0 or later to remediate this vulnerability. No workaround or temporary fix is available. AWS services are not impacted and require no action.
Description
CVE-2026-94450 is a denial of service vulnerability in s2n-quic, a Rust implementation of the QUIC protocol. The flaw occurs due to improper validation of the Destination Connection ID length when a server is configured to send Retry packets. An unauthenticated attacker can exploit this by sending a crafted UDP datagram to shut down the vulnerable server endpoint. This affects s2n-quic versions up to and including 1.88.0. AWS services are not impacted, and only server endpoints configured to issue Retry packets are vulnerable. The vulnerability is fixed in version 1.89.0. No workaround exists, so upgrading is required.