Skip to main content
VulnerabilityPublished

CVE-2026-94571: OpenStack Octavia · Code Injection

Affects OpenStack OctaviaSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.4 Critical · fixed in 18.0.1 : patch OpenStack Octavia as a priority.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.0.1, 17.0.1, 16.1.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Octavia and openstack/octavia to 18.0.1, 17.0.1 or 16.1.0.

Affected software

ProductAffectedFixed in
OpenStackOctaviaAffected
  • >=18.0.0 <18.0.1
Fixed in
  • 18.0.1
OpenStackOctaviaAffected
  • >=17.0.0 <17.0.1
Fixed in
  • 17.0.1
OpenStackOctaviaAffected
  • >=0.8.0 <16.1.0
Fixed in
  • 16.1.0
GitHubopenstack/octaviapkg:github/openstack/octaviaOther threatsAffected
  • >=0.8.0 <16.1.0
  • >=17.0.0 <17.0.1
  • >=18.0.0 <18.0.1
Fixed in
  • 16.1.0
  • 17.0.1
  • 18.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in OpenStack Octavia version 18.0.1. Users should upgrade to version 18.0.1 or later to remediate this vulnerability. Deployments not using the Amphora provider are not affected. No other mitigations are indicated.

Description

CVE-2026-94571 is a critical code injection vulnerability in OpenStack Octavia affecting the Amphora provider driver before version 18.0.1. The flaw allows an authenticated project member who owns a load balancer to inject arbitrary HAProxy directives via crafted L7 policy redirect_url and redirect_prefix fields. This occurs because control characters are not properly rejected and are written raw into the HAProxy configuration. Only deployments using the Amphora provider are impacted.

References

Community reviews

Loading reviews…