CVE-2026-9521: fraillt bitsery · Improper Validation of Specified Type of Input
Affects fraillt bitserySource CVE Database V5
Public exploit available · CVSS 6.3 Medium · fixed in 5.2.5 : patch fraillt bitsery as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.2.5
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| frailltbitsery | Affected
| Fixed in– |
GitHubfraillt/bitserypkg:github/fraillt/bitseryOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:fraillt:bitsery:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the fraillt bitsery library to version 5.2.5 or later, which contains the official fix for this vulnerability (patch 66d16516e24893bebc1c8af52bf2fe9ad0735061). No other mitigation steps are indicated by the vendor advisory.
Description
A security vulnerability has been detected in fraillt bitsery up to 5.2.4. Affected is the function loadFromSharedState in the library include/bitsery/ext/std_smart_ptr.h. Such manipulation leads to improper validation of specified type of input. It is possible to launch the attack remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 5.2.5 is able to address this issue. The name of the patch is 66d16516e24893bebc1c8af52bf2fe9ad0735061. Upgrading the affected component is advised.
References
- vuldb.com/vuln/365541 (opens in a new tab)
- vuldb.com/vuln/365541/cti (opens in a new tab)
- vuldb.com/submit/814457 (opens in a new tab)
- gist.github.com/TrebledJ/750abc64a826f19dd2d6774724629b71 (opens in a new tab)
- github.com/fraillt/bitsery/blob/master/CHANGELOG.md (opens in a new tab)
- github.com/fraillt/bitsery/commit/66d16516e24893bebc1c8af52bf2fe9ad0735061 (opens in a new tab)
- github.com/fraillt/bitsery/releases/tag/v5.2.5 (opens in a new tab)
- github.com/fraillt/bitsery/ (opens in a new tab)