Skip to main content
VulnerabilityPublished

CVE-2026-95628: Apache Camel · Path Traversal

Affects Apache CamelSource CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 5.4 Medium : upgrade to 4.22.2 or 4.18.5 when convenient.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.22.2, 4.18.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache to 4.22.2 or 4.18.5.

Affected software

ProductAffectedFixed in
Apache Camelorg.apache.camel:camel-doclingAffected
  • >=4.19.0 <4.22.2
Fixed in
  • 4.22.2
Apache Camelorg.apache.camel:camel-doclingAffected
  • >=4.15.0 <4.18.5
Fixed in
  • 4.18.5
MavenApache Software Foundation/org.apache.camel:camel-doclingpkg:maven/Apache Software Foundation/org.apache.camel:camel-doclingOther threatsAffected
  • >=4.15.0 <4.18.5
  • >=4.19.0 <4.22.2
Fixed in
  • 4.18.5
  • 4.22.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Apache Camel versions 4.18.5 and 4.22.2; users should upgrade to these or later supported versions. Versions 4.15.x to 4.17.x and 4.19.x to 4.21.x are end-of-life and will not receive fixes, so upgrading to a supported release is necessary. For deployments unable to upgrade immediately, do not construct the CamelDoclingCustomArguments header from untrusted external inputs, remove this header from messages originating outside the deployment before they reach a docling endpoint, and ensure that consumers mapping incoming message headers drop the Camel header namespace to prevent unauthorized header propagation.

Description

CVE-2026-95628 is a path traversal vulnerability in the Apache Camel Docling component affecting versions from 4.15.0 before 4.18.5 and from 4.19.0 before 4.22.2. The flaw allows absolute paths to bypass path safety checks, enabling an attacker who can control custom arguments to point the docling process to arbitrary directories accessible by the Camel process. This undermines the intended directory restriction and can lead to unauthorized access or impact on the system. The issue is fixed in Apache Camel versions 4.18.5 and 4.22.2, with earlier unsupported versions requiring upgrade to a supported release. Mitigations include avoiding use of externally sourced custom arguments and filtering headers that carry these arguments.

References

Community reviews

Loading reviews…