CVE-2026-95657: dgtlmoon Changedetection.io · Cross-site Scripting
Affects dgtlmoon Changedetection.ioSource CVE Database V5
Public exploit available · CVSS 5.1 Medium · fixed in 0.60.1 : patch dgtlmoon Changedetection.io as a priority.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.60.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 22 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| dgtlmoonChangedetection.io | Affected
| Fixed in– |
GitHubdgtlmoon/changedetection.iopkg:github/dgtlmoon/changedetection.ioOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:dgtlmoon:changedetection.io:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade dgtlmoon Changedetection.io to version 0.60.1 or later, which contains the official fix for this vulnerability. No other mitigation is indicated by the vendor advisory.
Description
A vulnerability was determined in dgtlmoon Changedetection.io up to 0.55.8. This issue affects the function setCurrentSelectedText of the file changedetectionio/static/js/visual-selector.js of the component Visual Selector. Executing a manipulation of the argument s can lead to cross site scripting. The attack can be launched remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 0.60.1 is capable of addressing this issue. This patch is called aac6fcfa594f17511b8ff73e5eaa4f6c33899de0. It is suggested to upgrade the affected component.
References
- vuldb.com/vuln/408413 (opens in a new tab)
- vuldb.com/vuln/408413/cti (opens in a new tab)
- vuldb.com/cve/CVE-2026-95657 (opens in a new tab)
- vuldb.com/submit/896587 (opens in a new tab)
- github.com/herantong/cve/blob/main/changedetection.io_xss-visual-selector_CWE-79 (opens in a new tab)
- github.com/dgtlmoon/changedetection.io/pull/4282 (opens in a new tab)
- github.com/dgtlmoon/changedetection.io/commit/aac6fcfa594f17511b8ff73e5eaa4f6c33899de0 (opens in a new tab)
- github.com/dgtlmoon/changedetection.io/releases/tag/0.60.1 (opens in a new tab)
- github.com/dgtlmoon/changedetection.io/ (opens in a new tab)