CVE-2026-9579: JeecgBoot · Improper Access Controls
Affects JeecgBootSource CVE Database V5
Public exploit available · CVSS 5.3 Medium.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| JeecgBoot | Affected
| Fixed in– |
GitHubjeecgboot/JeecgBootpkg:github/jeecgboot/JeecgBootOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:jeecgboot:jeecgboot:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the affected JeecgBoot component to version 3.9.2, which addresses this vulnerability. Since the vendor advisory or patch links are not explicitly provided, confirm the upgrade from official JeecgBoot sources before deployment. Patch status is not explicitly confirmed beyond the recommendation to upgrade; verify vendor advisories for the latest remediation guidance.
Description
CVE-2026-9579 is a medium severity vulnerability in JeecgBoot versions up to 3.9.1. It involves improper access controls in the user.getUsername function within the SysUser component, specifically in the /sys/user/login/setting/userEdit file. The vulnerability arises from manipulation of the userIdentity argument, allowing remote attackers to potentially bypass access restrictions. An exploit has been publicly disclosed. Upgrading to JeecgBoot version 3.9.2 is recommended to address this issue.
References
- vuldb.com/vuln/365635 (opens in a new tab)
- vuldb.com/vuln/365635/cti (opens in a new tab)
- vuldb.com/submit/817891 (opens in a new tab)
- github.com/jeecgboot/JeecgBoot/issues/9596 (opens in a new tab)
- github.com/jeecgboot/JeecgBoot/issues/9596 (opens in a new tab)
- github.com/jeecgboot/JeecgBoot/releases/tag/v3.9.2 (opens in a new tab)
- github.com/jeecgboot/JeecgBoot/ (opens in a new tab)