CVE-2026-9604: JeecgBoot · Improper Access Controls
Affects JeecgBootSource CVE Database V5
Public exploit available · CVSS 5.3 Medium.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| JeecgBoot | Affected
| Fixed in– |
GitHubjeecgboot/JeecgBootpkg:github/jeecgboot/JeecgBootOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:jeecgboot:jeecgboot:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected JeecgBoot instances to version 3.9.2 or later, as this version addresses the improper access control vulnerability. Since the product is not a cloud service and no official remediation level is stated, applying the vendor's fixed version is the recommended action. Patch status is confirmed by the upgrade recommendation in the advisory.
Description
A vulnerability was detected in JeecgBoot up to 3.9.1. This vulnerability affects unknown code of the component AiragModelController. The manipulation of the argument list/queryById results in improper access controls. The attack can be executed remotely. The exploit is now public and may be used. Upgrading to version 3.9.2 is able to resolve this issue. The affected component should be upgraded.
References
- vuldb.com/vuln/365677 (opens in a new tab)
- vuldb.com/vuln/365677/cti (opens in a new tab)
- vuldb.com/submit/818123 (opens in a new tab)
- github.com/jeecgboot/JeecgBoot/issues/9599 (opens in a new tab)
- github.com/jeecgboot/JeecgBoot/issues/9599 (opens in a new tab)
- github.com/jeecgboot/JeecgBoot/releases/tag/v3.9.2 (opens in a new tab)
- github.com/jeecgboot/JeecgBoot/ (opens in a new tab)