CVE-2026-96357: Drupal Webform · Cross-site Scripting
Affects Drupal WebformSource CVE Database V5
Not known to be exploited · CVSS 4.6 Medium : upgrade to 6.3.1 or 6.2.12 when convenient.
Data as of 26 Oct 2026, 11:42 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-10-22.
- Patch
- Available – fixed in 6.3.1, 6.2.12
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Drupal Webform to 6.3.1 or 6.2.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DrupalWebform | Affected
| Fixed in
|
| DrupalWebform | Affected
| Fixed in
|
AI-suggested
Upgrade Drupal Webform to version 6.2.12 or later, or 6.3.1 or later, where this vulnerability has been fixed. No other mitigation actions are indicated by the vendor advisory.
Description
CVE-2026-96357 is a stored cross-site scripting (XSS) vulnerability in the Drupal Webform module. It affects Webform versions from 0.0.0 up to but not including 6.2.12, and versions from 6.3.0 up to but not including 6.3.1. The vulnerability arises from improper neutralization of input during web page generation, allowing an attacker to inject malicious scripts. The issue has been fixed in versions 6.2.12 and 6.3.1.