Skip to main content
VulnerabilityPublished

CVE-2026-96361: Drupal Webform · Cross-site Scripting

Affects Drupal WebformSource CVE Database V5

0

Not known to be exploited · CVSS 4.6 Medium : upgrade to 6.3.1 or 6.2.12 when convenient.

Data as of 26 Oct 2026, 14:18 UTC

CVSS 3.1 base score
4.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.3.1, 6.2.12
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Drupal Webform to 6.3.1 or 6.2.12.

Affected software

ProductAffectedFixed in
DrupalWebformAffected
  • >=6.3.0 <6.3.1
Fixed in
  • 6.3.1
DrupalWebformAffected
  • <6.2.12
Fixed in
  • 6.2.12

AI-suggested

If you cannot patch yet, consider applying input validation or output encoding workarounds if feasible.

Description

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Webform allows Cross-Site Scripting (XSS). This issue affects Webform versions: from 0.0.0 to 6.2.12, from 6.3.0 to 6.3.1.

References

Community reviews

Loading reviews…