Skip to main content
VulnerabilityPublished Updated

CVE-2026-96442: GNU Emacs · Code Injection

Affects GNU EmacsSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 7.8 High : upgrade to 31.2 soon.

Data as of 6 Nov 2026, 11:41 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.17.8
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 31.2
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade GNU Emacs and emacs-mirror/emacs to 31.2.

Affected software

ProductAffectedFixed in
GNU EmacsemacsAffected
  • <31.2
Fixed in
  • 31.2
GitHubemacs-mirror/emacspkg:github/emacs-mirror/emacsOther threatsAffected
  • <31.2
Fixed in
  • 31.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in GNU Emacs version 31.2. Users should upgrade to version 31.2 or later to remediate this vulnerability. Until patched, users should avoid opening or editing untrusted text files with Emacs and exercise caution when handling files from unknown or suspicious sources to prevent arbitrary code execution.

Description

A code execution flaw was found in Emacs, affecting versions prior to 31.2. The Flymake mode using language backends other than Lisp would execute arbitrary code from the edited file while performing syntax checking. Viewing or editing untrusted files using Emacs could lead to arbitrary code execution with the privileges of the user running Emacs.

References

Community reviews

Loading reviews…