Skip to main content
VulnerabilityPublished

CVE-2026-96677: Apache Juneau · Cross-site Scripting

Affects Apache JuneauSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 10.0 Critical : upgrade to 9.2.1 as a priority.

Data as of 5 Nov 2026, 12:04 UTC

CVSS 4.0 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (apache)CVSS 4.010.0
Patch
Available – fixed in 9.2.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Apache Juneau and org.apache.juneau/juneau-marshall to 9.2.1.

Affected software

ProductAffectedFixed in
Apache Juneauorg.apache.juneau:juneau-marshallAffected
  • <9.2.1
Fixed in
  • 9.2.1
Mavenorg.apache.juneau/juneau-marshallpkg:maven/org.apache.juneau/juneau-marshallOther threatsAffected
  • <9.2.1
Fixed in
  • 9.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Juneau to version 9.2.1 or later, where this vulnerability is fixed. Since the vendor has provided an official fix, applying this update is the recommended remediation. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-96677 is a critical cross-site scripting (XSS) vulnerability in Apache Juneau affecting versions prior to 9.2.1. The issue arises because HTML document serialization does not encode variable substitutions in page chrome elements such as headers and navigation bars. Applications that include request-derived variables in these areas without encoding them are vulnerable to XSS attacks. The default chrome does not use request variables, so only customized applications are affected. The vulnerability is fixed in Apache Juneau version 9.2.1.

References

Community reviews

Loading reviews…