Skip to main content
VulnerabilityPublished Updated

CVE-2026-96749: MongoDB Python Driver · Integer Overflow or Wraparound

Affects MongoDB Python DriverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 4.18.2 soon.

Data as of 7 Nov 2026, 23:24 UTC

CVSS 4.0 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.18.2
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade MongoDB Python Driver to 4.18.2.

Affected software

ProductAffectedFixed in
MongoDBPython DriverAffected
  • >=1.9.0 <4.18.2
Fixed in
  • 4.18.2

AI-suggested

If you cannot patch yet, avoid processing unusually large BSON documents or untrusted large inputs in applications using affected versions.

Description

CVE-2026-96749 is an integer overflow vulnerability in the BSON document encoding component of the MongoDB Python Driver's native extension. It occurs when a single document is constructed from a very large amount of user-supplied data, causing size arithmetic to overflow a signed 32-bit integer. This can lead to a write outside the bounds of an allocated buffer within the application's process. The vulnerability affects versions from 1.9.0 up to but not including 4.18.2. No exploits are known in the wild, and the vulnerability has a high severity rating with a CVSS score of 7.5.

References

Community reviews

Loading reviews…