Skip to main content
VulnerabilityPublished

CVE-2026-96756: orval · Code Injection

Affects orvalSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.2 Critical : upgrade to 8.30.0 as a priority.

Data as of 7 Nov 2026, 23:24 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 59% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.30.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade orval to 8.30.0.

Affected software

ProductAffectedFixed in
orval-labsorvalAffected
  • <8.30.0
Fixed in
  • 8.30.0

AI-suggested

A fixed version 8.30.0 of orval is available that addresses this code injection vulnerability. Users should upgrade to version 8.30.0 or later to remediate this issue. No other mitigations are indicated.

Description

orval versions before 8.30.0 contain a code injection vulnerability in the @orval/core factory generator that fails to escape date default values in new Date() calls. Attackers can inject arbitrary expressions through apostrophes in OpenAPI schema defaults to execute code with the privileges of the consumer process when factoryMethods and useDates options are enabled.

References

Community reviews

Loading reviews…