Skip to main content
VulnerabilityPublished

CVE-2026-9746: MongoDB Server · Reachable Assertion

Affects MongoDB ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High · fixed in 8.3.3 : patch MongoDB Server soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.3.3, 8.2.10, 8.0.24 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade MongoDB Server to 8.3.3, 8.2.10, 8.0.24 or 7.0.35.

Affected software

ProductAffectedFixed in
MongoDBMongoDB ServerAffected
  • >=8.3.0 <8.3.3
Fixed in
  • 8.3.3
MongoDBMongoDB ServerAffected
  • >=8.2.0 <8.2.10
Fixed in
  • 8.2.10
MongoDBMongoDB ServerAffected
  • >=8.0.0 <8.0.24
Fixed in
  • 8.0.24
MongoDBMongoDB ServerAffected
  • >=7.0.0 <7.0.35
Fixed in
  • 7.0.35

AI-suggested

If you cannot patch yet, restrict access to authenticated users and monitor for attempts to use $changestreams with $_requestReshardingResumeToken and the exchange option. Avoid issuing such statements if possible.

Description

CVE-2026-9746 is a high-severity vulnerability in MongoDB Server that causes the server to crash due to a reachable assertion failure when using $changestreams and $_requestReshardingResumeToken with the exchange option. The issue requires the user to be logged in but does not require special privileges. Affected versions include 7.0.0, 8.0.0, 8.2.0, and 8.3.0. There is no confirmed patch or official remediation available at this time.

References

Community reviews

Loading reviews…