Skip to main content
VulnerabilityPublished

CVE-2026-9751: MongoDB Server · Sensitive Data in Logs

Affects MongoDB ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.8 Medium · fixed in 8.3.3 : update MongoDB Server when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.3.3, 8.2.10, 8.0.24 +1
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade MongoDB Server to 8.3.3, 8.2.10, 8.0.24 or 7.0.35.

Affected software

ProductAffectedFixed in
MongoDBMongoDB ServerAffected
  • >=8.3.0 <8.3.3
Fixed in
  • 8.3.3
MongoDBMongoDB ServerAffected
  • >=8.2.0 <8.2.10
Fixed in
  • 8.2.10
MongoDBMongoDB ServerAffected
  • >=8.0.0 <8.0.24
Fixed in
  • 8.0.24
MongoDBMongoDB ServerAffected
  • >=7.0.0 <7.0.35
Fixed in
  • 7.0.35

AI-suggested

If you cannot patch yet, it is recommended to restrict access to MongoDB log files to trusted administrators only and avoid setting the ldapQueryPassword parameter at runtime if possible.

Description

CVE-2026-9751 is a vulnerability in MongoDB Server where the ldapQueryPassword parameter, when set via the runtime setParameter command, is logged in plain text to the mongod.log file. This exposure of sensitive information in logs can lead to unauthorized disclosure of LDAP passwords. The issue affects MongoDB Server versions 7.0.0, 8.0.0, 8.2.0, and 8.3.0. The vulnerability has a medium severity with a CVSS 4.0 base score of 6.8. There are no known exploits in the wild at this time.

References

Community reviews

Loading reviews…