Skip to main content
VulnerabilityPublished Updated

CVE-2026-97580: Linux kernel · media: rkvdec: bound HEVC tile loops and PPS id to the array capacity

Affects Linux kernelSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High : upgrade to 81ad46bb33d8fd279aaa33af5296c648814c964b or 03beb248d8a7bab30559a60d4df81f167e63b9e3 soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 81ad46bb33d8fd279aaa33af5296c648814c964b, 03beb248d8a7bab30559a60d4df81f167e63b9e3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Linux kernel to 81ad46bb33d8fd279aaa33af5296c648814c964b or 03beb248d8a7bab30559a60d4df81f167e63b9e3.

Affected software

ProductAffectedFixed in
LinuxLinuxAffected
  • ≥ 3595375c2301653d5440d54b396df03499686c20, < 81ad46bb33d8fd279aaa33af5296c648814c964b
Fixed in
  • 81ad46bb33d8fd279aaa33af5296c648814c964b
LinuxLinuxAffected
  • ≥ 3595375c2301653d5440d54b396df03499686c20, < 03beb248d8a7bab30559a60d4df81f167e63b9e3
Fixed in
  • 03beb248d8a7bab30559a60d4df81f167e63b9e3
LinuxLinuxAffected
  • =6.19
Fixed in–

AI-suggested

A fix is available and has been applied in the Linux kernel commits identified by hashes 81ad46bb33d8fd279aaa33af5296c648814c964b and 03beb248d8a7bab30559a60d4df81f167e63b9e3. Users should update to the patched Linux kernel version 6.19 or later containing these fixes to remediate the vulnerability.

Description

CVE-2026-97580 is a high-severity vulnerability in the Linux kernel's media subsystem, specifically in the rkvdec HEVC decoder. The flaw involves unbounded loops and array indexing based on untrusted picture parameter set (PPS) data, which could lead to out-of-bounds writes in hardware tables. The issue has been fixed by bounding tile loops and validating PPS IDs before indexing arrays.

References

Community reviews

Loading reviews…