Skip to main content
VulnerabilityPublished Updated

CVE-2026-97602: Linux kernel · inet: frags: invalidate queues before flushing them

Affects Linux kernelSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High · fixed in ff83367cda8eefbd62007ef1dff4f8104226d18a : patch Linux kernel soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in ff83367cda8eefbd62007ef1dff4f8104226d18a, bf3d6c44c84c57e8a4bb7f40ad95b64f9b0198ba, b824476c56a153934c67c9e0f873e1fd967743d6 +5
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
LinuxLinuxAffected
  • >=6.6.143 <6.6.158
  • >=6.12.93 <6.12.111
  • >=6.18.3 <6.18.53
Fixed in
  • ff83367cda8eefbd62007ef1dff4f8104226d18a
  • bf3d6c44c84c57e8a4bb7f40ad95b64f9b0198ba
  • b824476c56a153934c67c9e0f873e1fd967743d6
  • b9d77f1652e79e58eac48430d0431c329137efcc
  • 7cb5f4643a7fcdbfbee1fad3cdfc678add62d378
  • 6.18.53
  • 6.12.111
  • 6.6.158
LinuxLinuxAffected
  • =6.19
Fixed in–

AI-suggested

Fixed versions are available and should be applied. The vulnerability is resolved by killing incomplete fragment queues before flushing and properly managing queue ownership and timer references. Users should upgrade to Linux kernel versions 6.6.158, 6.12.111, 6.18.53, or 6.19 where the issue is fixed. No additional mitigation is required beyond applying these official fixes.

Description

CVE-2026-97602 is a high-severity vulnerability in the Linux kernel's IPv6 fragment reassembly code. It involves improper invalidation of fragment queues before flushing, which can lead to heap corruption due to out-of-bounds memory access. This flaw can be exploited for local privilege escalation in environments with unprivileged network namespaces. The issue arises from stale reassembly metadata being reused and incomplete queues not being properly killed before flushing.

References

Community reviews

Loading reviews…