CVE-2026-98083: Linux kernel · btrfs: fix transaction use-after-free in raid stripe insertion
Affects Linux kernelSource CVE Database V5
Not known to be exploited · CVSS 7.0 High · fixed in b185bdf30313e213fa1c887fe22fc3d513c061d9 : patch Linux kernel soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in b185bdf30313e213fa1c887fe22fc3d513c061d9, b7b94923b3b5774d85a2a7c8d6eb9e3e0ef66685, a8813a923f9e43f788b357fb55c35f7f6ed6f98c +3
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 25 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| LinuxLinux | Affected
| Fixed in
|
| LinuxLinux | Affected
| Fixed in– |
AI-suggested
A fix for this vulnerability is available in Linux kernel version 6.6.158 and later. Users and administrators should upgrade affected Linux kernel versions to 6.6.158 or newer to remediate this issue. No additional mitigation steps are indicated by the vendor advisory.
Description
CVE-2026-98083 is a use-after-free vulnerability in the Linux kernel's btrfs filesystem related to transaction handling during RAID stripe insertion. The flaw occurs when a RAID stripe extent allocation fails, causing the transaction to be ended prematurely twice, leading to use-after-free of the transaction handle. This vulnerability affects Linux kernel versions from 6.6.130 up to but not including 6.6.158, and version 6.7. It has been fixed in version 6.6.158 and later commits.
References
- git.kernel.org/stable/c/089d9c45ea49ffffe55a8fe08d0ce2536626e90a (opens in a new tab)
- git.kernel.org/stable/c/b185bdf30313e213fa1c887fe22fc3d513c061d9 (opens in a new tab)
- git.kernel.org/stable/c/2fbfd02bdfe12b20bd3cc7a3190fb32e3f7072f5 (opens in a new tab)
- git.kernel.org/stable/c/b7b94923b3b5774d85a2a7c8d6eb9e3e0ef66685 (opens in a new tab)
- git.kernel.org/stable/c/a8813a923f9e43f788b357fb55c35f7f6ed6f98c (opens in a new tab)