Skip to main content
VulnerabilityPublished Updated

CVE-2026-98228: Linux kernel · mips: select CONFIG_WEAK_REORDERING_BEYOND_LLSC from CONFIG_EYEQ

Affects Linux kernelSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High : upgrade to bbc448c541ed90d52f9ec22f17394304e3bf170e or 3f017c2ca8c31a1e135dd87be647096866d6b196 soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in bbc448c541ed90d52f9ec22f17394304e3bf170e, 3f017c2ca8c31a1e135dd87be647096866d6b196
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Linux kernel to bbc448c541ed90d52f9ec22f17394304e3bf170e or 3f017c2ca8c31a1e135dd87be647096866d6b196.

Affected software

ProductAffectedFixed in
LinuxLinuxAffected
  • ≥ fbe0fae601b780622fcb7034a479fa161645b9f4, < bbc448c541ed90d52f9ec22f17394304e3bf170e
Fixed in
  • bbc448c541ed90d52f9ec22f17394304e3bf170e
LinuxLinuxAffected
  • ≥ fbe0fae601b780622fcb7034a479fa161645b9f4, < 3f017c2ca8c31a1e135dd87be647096866d6b196
Fixed in
  • 3f017c2ca8c31a1e135dd87be647096866d6b196
LinuxLinuxAffected
  • =6.11
Fixed in–

AI-suggested

A fix is available and has been applied in Linux kernel version 6.11. The remediation involves selecting CONFIG_WEAK_REORDERING_BEYOND_LLSC from CONFIG_EYEQ to ensure proper synchronization of atomic operations on affected CPUs. Users and administrators should upgrade to Linux kernel 6.11 or later to mitigate this vulnerability. No additional mitigation steps are required beyond applying the official fix.

Description

CVE-2026-98228 is a vulnerability in the Linux kernel affecting MIPS architecture, specifically on I6500 CPU cores. The issue arises because load-linked (lld) and store-conditional (scd) instructions do not provide ordering guarantees, which can lead to kernel crashes due to improper synchronization in atomic operations. This flaw can cause kernel paging faults and system instability when certain atomic operations are reordered by the CPU. The vulnerability has been fixed by selecting CONFIG_WEAK_REORDERING_BEYOND_LLSC from CONFIG_EYEQ to inject necessary synchronization instructions around lld/scd loops.

References

Community reviews

Loading reviews…