Skip to main content
VulnerabilityPublished Updated

CVE-2026-98254: Linux kernel · swiotlb: use the adjusted address for the highmem page lookup

Affects Linux kernelSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High · fixed in b7d7914a9ae3097e63d113007e4fb44d33d515b1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in b7d7914a9ae3097e63d113007e4fb44d33d515b1, aa4709813b29db89f2307f968db5d24925dcdeb1, 0219b72f5c209732b2f03a8cc0d7240b5e428a99 +3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
LinuxLinuxAffected
  • >=5.10.47 <5.11
  • >=5.12.14 <5.13
Fixed in
  • b7d7914a9ae3097e63d113007e4fb44d33d515b1
  • aa4709813b29db89f2307f968db5d24925dcdeb1
  • 0219b72f5c209732b2f03a8cc0d7240b5e428a99
  • 6e53b4d6afbde626255805d438cabb1cac482445
  • 5.13
  • 5.11
LinuxLinuxAffected
  • =5.13
Fixed in–

AI-suggested

A fix is available and has been incorporated in Linux kernel versions 5.11, 5.13, and related commits. Users and administrators should upgrade to these fixed versions to remediate the vulnerability. No additional mitigations are indicated beyond applying the official patches.

Description

CVE-2026-98254 is a high severity vulnerability in the Linux kernel's swiotlb subsystem affecting versions >=5.10.47 <5.11, >=5.12.14 <5.13, and =5.13. The flaw involves incorrect handling of adjusted addresses for high memory page lookups during DMA operations, causing data to be copied to or from incorrect memory pages. This can lead to data corruption and stale data issues. The vulnerability has been fixed in Linux kernel versions 5.11, 5.13, and related commits.

References

Community reviews

Loading reviews…