Skip to main content
VulnerabilityPublished Updated

CVE-2026-98318: Linux kernel · smb: client: validate absolute native symlink targets before NT fixups

Affects Linux kernelSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High · fixed in 6913ff607c2bc8694193e1fcc40bf16d75f35f16 : patch Linux kernel soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6913ff607c2bc8694193e1fcc40bf16d75f35f16, 23c240d9509e15f72e4112fc95f0160ab32ec430, 6.16
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Linux kernel to 6913ff607c2bc8694193e1fcc40bf16d75f35f16, 23c240d9509e15f72e4112fc95f0160ab32ec430 or 6.16.

Affected software

ProductAffectedFixed in
LinuxLinuxAffected
  • >=6.15.6 <6.16
Fixed in
  • 6913ff607c2bc8694193e1fcc40bf16d75f35f16
  • 23c240d9509e15f72e4112fc95f0160ab32ec430
  • 6.16
LinuxLinuxAffected
  • =6.16
Fixed in–

AI-suggested

A fix is available in Linux kernel version 6.16 and later. Users and administrators should upgrade affected Linux kernel versions (>=6.15.6 <6.16 and =6.16) to version 6.16 or later to remediate this vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-98318 is a high-severity vulnerability in the Linux kernel SMB client where absolute native symlink targets are not properly validated before NT fixups. This leads to buffer overflows due to incorrect assumptions about NT drive path prefixes, allowing a user with write access to a mounted share to trigger memory corruption.

References

Community reviews

Loading reviews…