Skip to main content
VulnerabilityPublished Updated

CVE-2026-98323: Linux kernel · RDMA/siw: Bound fragmented header copies by the remaining length

Affects Linux kernelSource CVE Database V5

0

Not known to be exploited · CVSS 9.8 Critical · fixed in eb4d7a946970469b3ab0c762432bf161d5b0836c : patch Linux kernel as a priority.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in eb4d7a946970469b3ab0c762432bf161d5b0836c, e6bdfdf3bcb02d0d626a45e8c98b7e63d2fddf9d, b72dcfb9bf1f0f0147cda03dc59e4002a315067f +10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
LinuxLinuxAffected
  • >=5.10.150 <5.10.271
  • >=5.15.75 <5.15.222
  • >=5.4.220 <5.5
  • >=5.19.17 <5.20
  • >=6.0.3 <6.1
Fixed in
  • eb4d7a946970469b3ab0c762432bf161d5b0836c
  • e6bdfdf3bcb02d0d626a45e8c98b7e63d2fddf9d
  • b72dcfb9bf1f0f0147cda03dc59e4002a315067f
  • af9f5b474a260ad23ffb9793d716a5e3bbce3b48
  • 8628f8ebf41669302513fb3f0bf0eba38b226742
  • 262dcd809723723ed8a4e05437ec7e9c21a8f17e
  • 9ff797e516dbc1ecb73701ec4c24055712d44411
  • 6.1
  • 5.20
  • 5.15.222
  • 5.10.271
  • 5.5
  • 2c6fbcf4bfac0b2b186acc8d91154c0fa24468a7
LinuxLinuxAffected
  • =6.1
Fixed in–

AI-suggested

This vulnerability has been fixed in multiple Linux kernel versions as listed in the established facts. Users and administrators should upgrade to one of the fixed versions (e.g., 5.10.271, 5.15.222, 5.20, 6.1, or later) to mitigate the risk. No additional mitigation steps are required beyond applying the official patches.

Description

CVE-2026-98323 is a critical vulnerability in the Linux kernel's RDMA/siw subsystem where fragmented header copies are not properly bounded by the remaining length. This flaw allows an out-of-bounds write due to incorrect calculation of header copy length across multiple TCP callbacks, potentially leading to memory corruption. The issue affects multiple Linux kernel versions and has been fixed in later releases.

References

Community reviews

Loading reviews…