Skip to main content
VulnerabilityPublished

CVE-2026-98514: Linux kernel · drm/nouveau: Fix gem reference leak in validate_init()

Affects Linux kernelSource CVE Database V5

0

Not known to be exploited · fixed in af2f48c12365866abb327d75c21a13bbde84719c : update Linux kernel when convenient.

Data as of 26 Oct 2026, 12:55 UTC

Severity
Low

Rated Low by Threat Radar's AI analysis · CVSS not yet scored by NVD

EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in af2f48c12365866abb327d75c21a13bbde84719c, 957619120c26d6727efd18504e6b488673d3900a, 8281930fc194ad448aaa5de8dd47fb6fb1cba327 +6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
LinuxLinuxAffected
  • >=4.17.12 <4.18
Fixed in
  • af2f48c12365866abb327d75c21a13bbde84719c
  • 957619120c26d6727efd18504e6b488673d3900a
  • 8281930fc194ad448aaa5de8dd47fb6fb1cba327
  • 74485cdc343060fce08f8f3990da524d783e43a7
  • 030e93fc91d55d9487b3b85fc0712bb795d77834
  • 9e13c398a23445baf38f0a59033dd9872a2bfe20
  • 5ea72f7b7139b123713a7983448f910bc4514d9e
  • 4.18
  • 3c80e069470cf73c357c9edb5ec5fba20e6f6a98
LinuxLinuxAffected
  • =4.18
Fixed in–
Linuxlinux/kernelpkg:deb/linux/kernelOther threatsAffected
  • >=4.17.12 <4.18
  • =4.18
Fixed in
  • 4.18

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix for this vulnerability is available and has been incorporated in Linux kernel version 4.18 and later. Users and administrators should upgrade to version 4.18 or apply the corresponding patches to resolve the gem reference leak.

Description

A vulnerability in the Linux kernel's drm/nouveau component caused a gem reference leak in the validate_init() function. The issue occurs when certain error paths break loops without releasing references, leading to resource leaks. This flaw has been fixed in Linux kernel version 4.18 and later.

References

Community reviews

Loading reviews…