Skip to main content
VulnerabilityPublished

CVE-2026-98545: Linux kernel · ata: libata-scsi: bound the ATA passthru sense descriptor writes

Affects Linux kernelSource CVE Database V5

0

Not known to be exploited · fixed in d9a7147b93624660626cd7c3b1143715699e1f5c : patch Linux kernel soon.

Data as of 26 Oct 2026, 17:16 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in d9a7147b93624660626cd7c3b1143715699e1f5c, c698f6deabf680f8f4a1727ef2dc80fe78815fbf, 80320b278fea07ffcda3f57b67b61658e0a4e1ca +4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
LinuxLinuxAffected
  • >=6.6.44 <6.6.158
  • >=6.10.3 <6.11
Fixed in
  • d9a7147b93624660626cd7c3b1143715699e1f5c
  • c698f6deabf680f8f4a1727ef2dc80fe78815fbf
  • 80320b278fea07ffcda3f57b67b61658e0a4e1ca
  • 1603abb0c50420e97cf4a1feddbd5e183c5fdf86
  • 80fbb0bc4d11683c88f2f9d3997ea02fcada5408
  • 6.11
  • 6.6.158
LinuxLinuxAffected
  • =6.11
Fixed in–

AI-suggested

Apply the official Linux kernel patches that fix this issue, available in versions 6.6.158, 6.11, and later. Upgrading to these fixed versions will remediate the vulnerability.

Description

A vulnerability in the Linux kernel's ATA passthru handling could allow a faulty or malicious ATAPI device to cause out-of-bounds reads and writes beyond a 96-byte buffer during error processing of ATA PASS-THROUGH commands. This issue has been fixed in Linux kernel versions 6.6.158, 6.11, and later.

References

Community reviews

Loading reviews…